Update auf das neue Major-Release 2.3

WordPress Logo
closeDieser Beitrag wurde vor 12 Jahren 10 Monaten 11 Tagen veröffentlicht. Die Informationen in diesem Beitrag sind möglicherweise veraltet. Bitte benutze die Suche oder das Archiv, um nach neueren Informationen zu diesem Thema zu suchen.

Jetzt habe ich WordPress auf die brandneue Version 2.3 aktualisiert. Klappte trotz neuer Datenbank-Struktur nahezu perfekt. Die Neuerungen könnt Ihr bei WordPress Deutschland nachlesen.

Die aktuelle Version soll die DE-Edition sein, von WordPress Deutschland herunter geladen. Ich weiß nur nicht, was hier Deutsch sein soll. Der komplette Admin-Bereich ist Englisch, und die generierten Angaben im Frontend, bei den Artikeln, ebenso. Das betrifft z.B. Datums-Angaben. Das Format ist im Theme festgelegt, aber Wochentags- und Monatsnamen werden auf englisch ausgegeben.

Dass es sich um die DE-Edition handeln muss, sehe im denn auch im Theme-Verzeichnis: Da findet sich nämlich auch die eingedeutschte Version des Standard-Themes. Auch in der Konfigurationsdatei ist „de_DE“ eingestellt, und die Sprachdatei befindet sich ebenfalls am vorgesehenen Ort.

Das nächste, was mir sauer aufstößt, ist die plötzlich fehlende WYSIWYG-Funktionalität im Editor, in dem ich diesen Beitrag schreibe. Und meine Smilies funktionieren auch nicht mehr.

Fazit: Hätte ich das vorher gewusst, hätte ich das Update nicht gemacht! Ich denke mal, durch die neue Datenbank-Struktur kann ich das nicht mehr rückgängig machen. Scheiße. Ich bin sauer.

Nachtrag: Ich habe soeben noch mal bei WordPress Deutschland gekramt, und bin dabei auf eine winzige Kleinigkeit gestoßen: Die Sprachdatei scheint, zumindest lt. Beschreibung, für Version 2.2 zu sein. Ist die mit Version 2.3 inkompatibel?

Was mich wundert: Jetzt beim Editieren des Beitrags stehen stehen mir die zuletzt bemängelten Funktionen zur Verfügung. WYSIWYG und Smilies funktionieren auf einmal.

Keep it Country, Markus

2 Kommentare

  1. Frank

    Wohl nicht ganz, denn in deinen älteren Artikeln werden die Umlaute UTF-8-kodiert dargestellt.
    Entferne mal die Kodierung in der wp-config.php, daran könnte es liegen.

    Antworten
    1. Markus (Beitrag Autor)

      Richtig Frank, aber durch den „Sprachwirrwar“ habe ich das selbst verursacht. Bin eben in der Datenbank am Ball, wo auch nicht alle Einstellungen stimmen.

      Antworten

Schreiben Sie einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

;) 
:) 
:D 
:( 
:/ 
:p 
:o 
:lol: 
:roll: 
:angry: 
:smoke: 
:mrgreen: 
:silence: 
:blush: 
:kiss: 
mehr...